Post a reply

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)


Topic review


Re: Here we are

OK, so you have a desktop shortcut to start WinSCP with explicit /ini switch to make it use INI file in non-standard location, right?

There's request to make shortcuts to sessions use the same configuration as creating instance:

Here we are


thanks for reply. I've attached the files. You can see that start from gui has set Parameter /ini automatically, start from Icon doesn't. I created the icon with the gui function "create Desktop Icon" and failed. I only added Parameter /log for getting a log file.



Re: Can't open connection with desktop icon, but with stored ses

WinSCP instance started by the shortcut obviously does not use the same configuration as the instance you have used to save the site.
Can you enable logging and attach a complete log file both for session opened from GUI and from shortcut?

Workaround found

Well, I think it's a bug. You can make it work by exporting the configuration and using the /ini parameter. This workaround fits my requirements, maybe yours too.

Regards KPW

Can't open connection with desktop icon, but with stored ses


here are the facs:
Winscp version: 5.5.4 (Build 4433) Portable
Windows version: 8.1 Prof.
FTP-Server: Filezilla 0.9.45 (installed on local machine)
Protocol: ftp

The situation is:
I have configured a session to the local running ftp server (test environment). If I first start client, choose saved session everything works well, session will be established.

I have created a desktop shortcut for the session. If I try to connect via desktop icon I get a message saying
"Connection to host rejected. Server denied SFTP connection but is listening on ftp-port. Do you want to connect via ftp? You should use a crypted connection".

On filezilla console I get the following message:
(000049)02.07.2014 21:12:40 - (not logged in) (> Connected, sending welcome message...
(000049)02.07.2014 21:12:40 - (not logged in) (> 220-FileZilla Server version 0.9.45 beta
(000049)02.07.2014 21:12:40 - (not logged in) (> 220-written by Tim Kosse (
(000049)02.07.2014 21:12:40 - (not logged in) (> could not send reply, disconnected.

I don't use a proxy. I have configured fire wall, if fire wall was the problem I wouldn't be able to connect via client. Why does the desktop icon try to connect via sftp, I have configured ftp in the session? What can I do?

Thanks for your help und best regards