Post a reply

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Options
Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)

Options

Topic review

Rim144

Cannot login in

I have just tried to login to my synology nas after seeing the lights on continuously. I'm using Syno dos on the iPad but it is stating "your account has been disabled, contact your administrator" please help.
martin

Re: DSM 5.1/WinSCP problem [SOLVED]

fracer2 wrote:

Change shell setting in WinSCP to "/bin/ash" (NOT "/bin/bash"). If you continue to have trouble, try also changing permissions on busybox: chmod 04755 /bin/busybox. Regards.

Thanks for sharing your resolution.
SimonOwl

Re: DSM 5.1/WinSCP problem [SOLVED]

Changing the shell to /bin/ash resolved the problem.
Thanks for your help, fracer2
fracer2

DSM 5.1/WinSCP problem [SOLVED]

Change shell setting in WinSCP to "/bin/ash" (NOT "/bin/bash"). If you continue to have trouble, try also changing permissions on busybox: chmod 04755 /bin/busybox. Regards.
fracer2

Confirming above problem when updating from Synology DSM 5.0 to 5.1, this morning. Partial log (tail):

Using username "joeper".
Prompt (7, SSH password, , &Password: )
Sent password
Access granted
Opening session as main channel
Opened main channel
Started a shell/command
--------------------------------------------------------------------------
Using SCP protocol.
Doing startup conversation with host.
Skipping host startup message (if any).
echo "WinSCP: this is end-of-file:0"
Waiting for data timed out, asking user what to do.
Asking user:
**Host is not communicating for 15 seconds.
SimonOwl

Cannot login as root to Synology NAS Diskstation 5.1

Winscp 515 and 562
Win 8.1
Protocol: SCP
GUI, with either interface style
Trying to login as root to Synology NAS, after the upgrade to Diskstation 5.1
Errors: Host is not communicating for more than 15 seconds; after aborting: Error skipping startup message. Your shell is probably incompatible with the application (BASH is recommended).
"Optimize connection buffer size" has no effect
Changing shell from default has no effect
Note: Putty with SSH continues to work with 5.1, SCP worked with Diskstation 5.0 and stopped with 5.1
Logs attached