Post a reply

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)


Topic review


It worked...

I found and deleted HKEY_LOCAL_MACHINE\SOFTWARE\Martin Prikryl and also HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Martin Prikryl.

After deleting the above keys and the original HKEY_CURRENT_USER\Software\Martin Prikryl, I ran the executable and it did in fact create and populate the WinSCP.ini file as documented.

Thanks for your help! :D

Re: Registry

And what about HKEY_LOCAL_MACHINE\SOFTWARE\Martin Prikryl\WinSCP 2?


Thank you for the quick response! I actually double-checked for the existence of the registry key [HKEY_CURRENT_USER\Software\Martin Prikryl] PRIOR to running the executable. However, when I launched WinSCP.exe it did not create an empty INI file as stated in the "Auto-selecting Storage" but instead created the registry key above.

Re: WinSCP Portable does not create INI file, instead REGISTRY

Well the description on Portable Use article is not complete, I have added a link to Auto-selecting Configuration Storage article:

Your problem can actually be that you already had configuration stored in registry.

WinSCP Portable does not create INI file, instead REGISTRY

The documentation states that when running the portable version, if no .INI file exists " tries to create one with default configuration (if it fails to do so it uses registry, preventing portable use)." Why would it "fail to do so"? In my case it does not create an INI but instead writes to the HKEY_CURRENT_USER registry hive. I can then go into the GUI and switch to INI under the Storage preference and that works no problem. I just wanted a way to run this so it never writes to the registry in the first place.

I just downloaded the latest version today (5.5.6 build 4746). I am running on Windows 7. Thanks! :D