Post a reply

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)


Topic review


Thanks for sharing your solution.

The resource monitor was not showing any process that was using very much memory, so I was going to use RAMMap to analyze my memory but after uninstalling the "Qualcomm Atheros Killer Network Manager", the problem stopped. No more excess RAM usage while downloading with SFTP.

So, if anyone has a Qualcomm Atheros Killer network card, be sure not to install the Qualcomm Atheros Killer Network Manager because it can cause memory errors and crash your computer during certain types of downloads.

Re: SFTP Uses Up All Available Memory, Then Windows Crashes

What uses the memory? The winscp.exe process? Or something else?

SFTP Uses Up All Available Memory, Then Windows Crashes

I don't think this is a bug in the WinSCP program, because I get the same problem when using a different SFTP program.

Any time I download using SFTP, my physical memory gets used up as I download, and eventually windows runs out of memory and crashes.

I've tried disabling prefetch and superfetch, and I also have disk caching turned off on all of my HDD/SSDs.

I'm using windows 8.1, which is totally up to date, as are all of the SFTP programs that I've tried downloading with. (latest version of WinSCP GUI in Commander mode)