Post a reply

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)


Topic review


Could not retrieve directory listing

Check the folder /etc/vsftpd/vsftpd_user_conf to see if your user have a file defined there. If yes, probably you will see some ssl settings in it
Change them, or comment them

If you needed to open port 21 locally (because you seem to have a restrictive firewall locally, that blocks even outgoing connection, what is not common, so it is not covered in the article), you need to open even data port range.

I have updated the article:

Hello Martin,

Thank you for your reply and the link which I have read.

Port scanning, it looks like just have port 21 open. For a passive mode connection, which is what I am trying to use, I didn't think I needed anything other than 21 open?

For a passive connection mode, which other ports are needed to receive the return data?

I have tried forcing the IP address in WinSCP, but this also fails.

It still doesn't answer the question of why I can connect via the ftp client in Windows File explorer and list the directories? If it was a open port issue then this would also presumably fail?



Re: Lost Connection - Could not retrieve directory listing

You have to open also ports for data connections, in addition to port 21 for control connection.
See also

Lost Connection - Could not retrieve directory listing


Having looked through the forums I couldn't see anything on this issue, so here goes.

I have recently changed routers from a BT Homehub 3 to a Homehub 5.

WinSCP 5.7 worked fine using the HH3.

I have configured the HH5 for port forwarding and confirmed port 21 is open etc.

Running WinSCP the dialogue box gets as far as

Reading remote directory...

I then get a Lost connection dialogue box with message:

Server sent passive reply with unroutable address, using host address instead.
Timeout detected. (data connection)
Could not retrieve directory listing.

Clicking on abort the following is appended to the dialogue box

Error listing directory '/array1'.

/array1 is the top level directory that I should be seeing.

Now the thing is that I can log in and see all of the directories on my NAS using the ftp client in Windows file explorer, so there is something different in the way WinSCP and Explorer are talking to the router.

Any advice to get WinSCP working with a HH5 would be most welcome.

Thank you.