Post a reply

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Options
Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)

Options

Topic review

martin

Re: Problem solved

Thanks for sharing your solution.
mwetmore

Problem solved

For an SFTP connection the server wanted the user-id to be domain\account. For FTP/SSL it worked without the domain. I was led toward a client problem because of the qualified compatibility with winSCP on the server vendor's web site.
martin

Re: Connecting to MOVEit Server with SFTP.

Can you try to enable Requires padding on SSH-2 RSA signatures?
https://winscp.net/eng/docs/ui_login_bugs

Please, post a log file for the new test (using the latest version of WinSCP).
mwetmore

Connecting to MOVEit Server with SFTP.

WinSCP Version 5.5.3 (Build 4214) (OS 6.1.7601 Service Pack 1 - Windows 7 Ultimate)
I upgraded to the latest .net assembly package, 5.7.0. Same results from the program and the GUI.

The Ipswitch web site (search for MOVEit) has winSCP listed as a supported FTP/SSL client but only partially supported as an FTP/SSH client. My application is VB.NET. What follows demonstrates this.

This works on another server but not on MOVEit
.Protocol = WinSCP.Protocol.Sftp

.HostName = My.Settings.Host.Trim
.UserName = My.Settings.SAPUID.Trim
.SshHostKeyFingerprint = My.Settings.HostFingerprint.Trim
.SshPrivateKeyPath = My.Settings.PrivateKeyFile.Trim


This works on MOVEit but I'd rather not have an exposed password
.Protocol = WinSCP.Protocol.Ftp

.FtpSecure = WinSCP.FtpSecure.Implicit
.HostName = My.Settings.Host.Trim
.UserName = My.Settings.SAPUID.Trim
.Password = My.Settings.Password.Trim


The server owner is moving from the one that works with SFTP to MOVEit. The private keys are identical on the two servers. The public keys have a PUB extension. Here's the failure point in a Debug 1 log:
. 2015-03-19 13:47:20.735 Offer of public key accepted

! 2015-03-19 13:47:20.735 Authenticating with public key "rsa-key-20140528"
. 2015-03-19 13:47:20.906 Sent public key signature
. 2015-03-19 13:47:20.906 Waiting for the server to continue with the initialization
. 2015-03-19 13:47:20.922 Detected network event
! 2015-03-19 13:47:20.922 Server refused public-key signature despite accepting key!
. 2015-03-19 13:47:20.953 Server refused public-key signature despite accepting key!
. 2015-03-19 13:47:20.953 Prompt (7, SSH password, , &Password: )

Have you had any contact with Ipswitch regarding this? I mention the PUB extension because (Googling) that may have solved similar problems on other servers. I have asked for it to be removed. That may take a couple of days.

Could it have something to do with the private key permissions? I've had that cause problems.

Thanks in advance.

Michael Wetmore.