Post a reply

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)


Topic review


Re: Open host fails with installed WinSCP

MatsW wrote:

But then the batch file didn't work.

That's pretty vague.
What does not work?

Please attach a full log both for a run with a standalone and installed WinSCP.

To generate log file, use /log=path_to_log_file command-line argument. Submit the log with your post as an attachment. Note that passwords and passphrases not stored in the log. You may want to remove other data you consider sensitive though, such as host names, IP addresses, account names or file names (unless they are relevant to the problem). If you do not want to post the log publicly, you can mark the attachment as private.

Note that installed and standalone binaries are identical.

Open host fails with installed WinSCP


I started to test WinSCP using the executables from, and put them in my test directory. I then created a batch file to list files on a remote host: sftp://root@ /command ^
"call ls" ^

This worked fine, so then I ran the installer in winscp572setup.exe and removed the local executables. I checked the option to add WinSCP to PATH. But then the batch file didn't work.

So then I copied the executables from back to my local directory, and now my batch file worked. So then I removed them again, and BINGO! Now the installed version of WinSCP connects to the remote host.

Obviously the standalone version does something to the registry which the installed version needs to be able to work. And this setting is removed when the installer runs (or it sets some default value which doesn't work)