Post a reply

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)


Topic review



I looked through the forums for the specific message I had seen, but of course, I can't find it. I promise it's out there somewhere -- I wouldn't have (temporarily) walked away from WinSCP if I hadn't seen it :)

It was entirely my fault for putting the CALL string in quotes, or I likely would have had this working the first try last Friday. Nothing but a "doh" on me when all is said and done.

With this corrected, my transfer is now working perfectly. WinSCP to the rescue! :)


After revisiting WinSCP, I realized my error was putting the arguments to the CALL statement in quotes (in my script). I removed the quotes, and the CALL SITE.... function worked just fine.

If I can find a link to the post that said it wasn't supported, which I apparently misunderstood, I'll post it in a moment.

soonerdave wrote:

I found a post, albeit a bit old, explicitly stating that "QUOTE SITE" is not supported. I'll have to find a different FTP/S client solution.

What post was that?

Anyway, it is supported.

Use CALL SITE RECFM=FB LRECL=114 CYL to call SITE RECFM=FB LRECL=114 CYL FTP command on the server.

After searching the forums a bit more, I've found that WinSCP cannot support the functionality I require.

I found a post, albeit a bit old, explicitly stating that "QUOTE SITE" is not supported. I'll have to find a different FTP/S client solution.

How to make "CALL" work properly for FTP/S connection


I have configured WinSCP to connect to an FTP/S server using explicitSSL. I am connecting to an IBM MVS server to upload a small set of data, and then exit. No external or secondary processing. The connect works fine.

Before "PUT"ting the file, I need to issue a "QUOTE SITE" command, and it appears the intended protocol for WinSCP is to use the CALL statement in a script to accomplish it. Each time, however, the CALL fails. I've tried:


and neither has worked. (Over the course of today, I've tried somewhere between six and 42 billion combinations of this, and nothing's come close). I've even tried just doing a direct QUOTE SITE command, which errors out as an invalid command. I'm obviously having a brain cramp and not understanding what I'm doing wrong.

In order to use WinSCP for this particular project (migrating an existing/working FTP transfer process that uses these existing commands), I *have* to figure out what I'm doing wrong, or if perhaps what I am attempting just isn't supported under FTP/S in WinSCP.

Are remote commands simply not supported in this scenario? Or am I just missing something really, really obvious?

Many thanks,