Post a reply

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)


Topic review


hello Martin,

thanks for your reply.
you are correct, that was the problem.

I apologize for wasting your time :-( I did take the time to research the problem, both on Google and in the documentation, but I had missed this (I didn't think there was a connection).

Congratulations for your success and keep up the good work!

best regards,

When I double-click a file, WinSCP opens it as a folder (and fails)


For some reason, with a particular server of mine, WinSCP won't allow me to double-click to edit a file.
The server runs Debian 7 64 bits.

When I double click any file, for example /root/index.php (the file is listed normally in WinSCP, it has the icon for PHP files), WinSCP tries to actually browse /root/index.php/ as a folder. And it fails, giving me an error message.

Normally, from the settings I've configured, double clicking the file should open the editor (and thats what it does for every other of my servers).

A screenshot of the error message: <invalid hyperlink removed by admin>

What I've tried to fix the problem
- I have checked the settings for double clicking: opening/editing/etc all options have no effect
- I have upgraded to the latest version of WinSCP
- I have tried logging in with other servers that I own: it works fine. It's only happening for this server.

It didn't use to do that, I don't know at which point it started doing that...

Any ideas?

PS: just donated $19 to Martin by Paypal (my first name is Clement)