Post a reply

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)


Topic review


Re: Works!

I have already implemented switch to optionally disable UTF-8 decoding. It will be included in the next release.

It have default value "auto" to automatically disable it for WAC server and enable it for all other servers. I may be forced to "on" when other server with the bug is found. Please let me know it such case so I can include it to the autodetection.


Hi Martin,

Thanks a lot ... the additional registry option works perfect. Could imagine that WAC server doesn't use UTF-8 for encoding ... Windows software and standards ;-(

Thanks once more for your fast reply!

Greetings from Vienna!


P.S.: Sent a donation by Kagi.

Re: Forgot some version information

Since version 3.7.1 WinSCP treats filenames for protocol SFTP v4 as UTF-8 encoded, as SFTP specification requires. Either your server does not encode filenames in UTF-8 (which would be violation of the protocol) or WinSCP decodes them incorectly.

1) Downgrade to WinSCP 3.7 beta. This is not recommended as all versions prior 3.7.1 suffered serious security issue.
2) If you can work with Windows registry add option "SFTPMaxVersion" to respective registry key of your stored session. Set the option to 3 (decimal). You may also switch configuration to INI file, if you are more familiar with it (see Storage tab of Preferences dialog). If you need more help on this, let me know.

Forgot some version information

I currently use 3.7.1!

What I also forgot to mention is that directory listing on this server worked with a previous version (some 3.x.x ... don't know the exact version number) of WinSCP.

Directory listing problems accessing WAC server with WinSCP

I get the following error when trying to access a directory with special characters (the name contains a "@"):

Error listing directory "/"
Error decoding UTF-8 string.

I think the problem could be that the server (WAC server) and the client uses different encodings ... maybe win1252 vs. UTF-8!?

Does anybody have an idea or can I set the encoding in WinSCP somewhere?

Many thanks in advance!

Rdiger Engelberger