Post a reply

Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)


Topic review


Re: Filemask on synchronize local fails

Thank you very much for your reply. I solved the problem. The solution is pretty stupid :-(

I already upgraded the WinSCP installation on the server. So I knew what the version should be. When I created a complete logfile and was checking for text I wanted to hide, I noticed an much older version number 4.2.9. Strange, becaause I checked the version in de WinSCP GUI.

It turns out that someone had the great idea to put the winscp.exe with te location of the scripts that call the executable. That way it is easier to copy to other servers. The downside is that an upgrade of WinSCP won't upgfrade that file......

After copying the WinSCP file to the second location the filemask worked and the log also looked different.

Re: Filemask on synchronize local fails

Please attach a full session log file showing the problem (using the latest version of WinSCP).

To generate log file, set Session.SessionLogPath. Submit the log with your post as an attachment. Note that passwords and passphrases not stored in the log. You may want to remove other data you consider sensitive though, such as host names, IP addresses, account names or file names (unless they are relevant to the problem). If you do not want to post the log publicly, you can mark the attachment as private.

Filemask on synchronize local fails


I keep getting this error:
> 2015-11-23 11:59:26.633 Script: synchronize -filemask="|*org.pdf" local
. 2015-11-23 11:59:26.633 Script: Failed

My goal is to exclude al files ending on org.pdf. If I ommit the -filemask option everything works but I get the undesired org.pdf files. It doesn't matter what filemask I use, it always gives an error.

My WinSCP version is 5.7.6 (Build 5874).