Post a reply

Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)


Topic review


Re: running via a batch file doesn't retrieve file requested


Run the batch file from Windows console (cmd.exe) to see its output.

Or enable logging and inspect the log.

To generate log file, use /log=path_to_log_file command-line argument. Submit the log with your post as an attachment. Note that passwords and passphrases not stored in the log. You may want to remove other data you consider sensitive though, such as host names, IP addresses, account names or file names (unless they are relevant to the problem). If you do not want to post the log publicly, you can mark the attachment as private.
Laurel running via a batch file doesn't retrieve file requested

I am new to this. I have run each of the steps in this .bat file individually in and it works. However, when I run it from a .bat file, I can see something flash on the screen as if winscp is opening but the file is not returned. What am I doing wrong?
Here is the using the /command in the .bat file: /command ^
"open" ^
"cd /edgar/data/1618921" ^
"get 0001567619-16-001640.txt c:\Users\Laurel\Documents\testthis.txt" ^
"close" ^

I had also tried running it as /script but it behaved the same way.
The code in the .txt script file is this:
option transfer binary
cd /edgar/data/1618921
get 0001567619-16-001640.txt c:\Users\Laurel\Documents\testthis.txt
the code in the .bat file to run the script is this: /script="C:\Users\Laurel\Documents\scripttest.txt"

Thanks for you help!

Laurel C