Post a reply

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)


Topic review


How do you capture the output?

The log lines with Script: prefix should be what WinSCP prints on the console.

Can you send me an email, so I can send you back a debug version of WinSCP to track the problem? Please include link back to this topic in your email. Also note in this topic that you have sent the email. Thanks.

You will find my address (if you log in) in my forum profile.

You don't have the CMD output in the logfile? line 252 to 270.
Please find attached again the logfile (I doubled checked before uploading)

You probably forgot to add the "CMD Output you get".

Please find attached the logfile. I've added at the end the CMD Output I get.
You can clearly see that in the logfile the lls command lists the files correctly but in the CMD output I get a incomplete list of files[/code]

Re: Cannot list files transfered by SFTP

Please attach a full session log file showing the problem (using the latest version of WinSCP). The log should show both the download and the lls command.

To generate the session log file, use /log=path_to_log_file command-line argument. Submit the log with your post as an attachment. Note that passwords and passphrases not stored in the log. You may want to remove other data you consider sensitive though, such as host names, IP addresses, account names or file names (unless they are relevant to the problem). If you do not want to post the log publicly, you can mark the attachment as private.

Cannot list files transfered by SFTP

Hello there!

I hope you can help me with my issue
I'm running WinSCP 5.7.7 in commande line. I run a script with the /script command, that gets files on a server via SFTP. Once the files are on my computer WinSCP is not able to see them anmore. When I launch the lls command it only lists the ".." <DIR>
Is there a trick to see my files?

I can see the files with the Windows Explorer and CMD/Powershell
I tried to change the rights on the files but with no result.
I tried to create a New File.txt and this file is correctly listed by the lls command.
Other files and folders from the computer are correctly listed.
The only files not listed seem to be the one I got from the SFTP transfert.

Thanks in advance.