Post a reply

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)


Topic review


Re: Cannot run WinSCP on WINPE operating system

WinSCP has a dependency on Windows Shell that is not present in the WinPE environment.

Cannot run WinSCP on WINPE operating system

We have a Windows build solution that uses WINPE USB build sticks to recover failed Windows machines. When the user boots from the USB stick, I want to perform a file synchronization with an HTTPS WEBDAV share. I prefer to use the portable version of WinSCP so I only have a couple of files to copy on to the stick.

When I try to run either the or the WinSCP.exe it doesn't enter the WinSCP command line it just simply returns command prompt.

I have tried using all versions of WinPE and added all the possible features but still no luck.

Has anyone managed to get WinSCP running in WINPE?