Post a reply

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)


Topic review


Solved: Renaming Issue with error 350 plus error 553 Can't rename file

The problem was on serverside as the operator of this site ( does not allow renaming of uploaded files. Or to be more exactly: allows only renaming to restricted patterns/suffixes.

- issue closed -

Renaming Issue with error 350 plus error 553 Can't rename file

Hi together, when renaming a file the server responds with this two errors:

350 Requested file action pending further information.
553 Can't rename file

This occurs in both scripting and dialog on a Windows Server 2008R2 using actual WinSCP 5.7.7 connected via FTP (FTPS: Implicit TLS/SSL) to a UNIX Type Apache FtpServer.

Opening the connection the server maps a virtual root directory "/" which is obviously not the root of the system. I then change directory to /outbox/ , upload a file to this directory and try to rename it. The file is fully uploaded and there is no issue/mismatch with the other topic "SFTP Renaming bug" while the .filepart is not done.

I can delete the file but I cannot rename it.
It is not a problem of rights. Here I would see a different error: "No permission to rename."

The significant sequence is

> 2016-08-29 12:08:34.509 Script: mv RG_0815_*.xml RG_0815_*.bak
. 2016-08-29 12:08:35.062 Moving file "RG_0815_571470_13939.xml" to "RG_0815_571470_13939.bak".
> 2016-08-29 12:08:35.062 RNFR /outbox/RG_0815_571470_13939.xml
< 2016-08-29 12:08:35.126 350 Requested file action pending further information.
> 2016-08-29 12:08:35.126 RNTO /outbox/RG_0815_571470_13939.bak
< 2016-08-29 12:08:35.205 553 Can't rename file.

Error 350 could be a result of incomplete pathnames. But the same error occurs even when I use WinSCP GUI and simply change one character of a files name.

Has anybody an idea how to solve this?

Kind regards