Post a reply

Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)


Topic review


Re: Tray icon when using script parameter

First of all, thank you very much for your help! <3
I finally managed to get what I want by adding the console-Parameter in the link and enabled the "minimize to tray"-function in the settings and changed it in the shortcut.

My final configuration (if anyone else has the same problem) is:

- Enable the "minize to tray"-option in the WinSCP settings
- The command of the shortcut is
"C:\Program Files (x86)\WinSCP\WinSCP.exe" /console /log="D:\log.log" /script="D:\script.txt"

- set "run as minimized" in the shortcut

Once again, thank you very much! :)

Re: Tray icon when using script parameter

Correct, use the /console switch. If you have minimizing to tray enabled in GUI, the script console will use it too.

Or you can use the /rawconfig Interface\MinimizeToTray=1 command-line switch.

If you want to start minimized, put the command to a shortcut and set the shortcut Run parameter to Minimized.

You have to use the /console parameter to see a window when you use winscp.exe.

Tray icon when using script parameter

Good evening everyone,

I was able to create a shortcut for WinSCP which opens my connection and keeps the two folders synchronized:
"C:\Program Files (x86)\WinSCP\WinSCP.exe" /log="D:\log.log" /script="D:\script.txt"

And the script.txt contains the commands "open", "keepuptodate" and "exit" generated by the program.

My question is following:
Everytime I start the shortcut, the folders get synchronized, but I can't see the WinSCP program. I know its in the Task Manager of Windows, where I can shut it down, but is it possible to see an additional tray icon?
I get the tray icon, when I start WinSCP and the synchronization manually and minimize it, but I would prefer the automatic way.

Any suggestions?

Thank you very much!