Post a reply

Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)


Topic review


Initial test successful

Changing to TimeoutInMilliseconds seems to have resolved the issue in my test script, I will update the prod script and wait for the next scheduled run to confirm. Thank you!

Re: GUI works, .NET assembly (PoSh) times out

The SessionOptions.Timeout is of type TimeSpan.
In PowerShell, if you assign a numeric value to a TimeSpan, it coverts to "ticks". 1 tick = 1/10000000 second. You effectively set zero timeout.
You may want to use SessionOptions.TimeoutInMilliseconds = 15000.

Or have WinSCP generate the code for you:

GUI works, .NET assembly (PoSh) times out

I have searched the forum and other sites, and tried a few things that were suggested, but I can't shake this problem. When I use the GUI tool, my SFTP uploads work fine, but when I call the .NET assembly from my Powershell script it always times out in the middle of the upload... (the test file I've been using is 708 Kb).

I have matched the settings in the script to those in the GUI as closely as possible, and already tried the suggestion found here of setting SendBuf to 0. I am attaching my script, and logs from both the GUI and the script. Any ideas or insights will be greatly appreciated!

Many thanks,