Post a reply

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)


Topic review


Re: Solution

Do you have any idea where did the 411 came from?


I have found the problem. The editor preference was wrong.

The "external editor" line said:

"C:\Program Files (x86)\Notepad++\notepad++.exe" 411 !.!

Changing it to:

"C:\Program Files (x86)\Notepad++\notepad++.exe" !.!

solved the problem.

Re: current local directory\411 doesn't exist. Create it?

It somehow has to something with how Notepad++ is opened.

I came across this article: git - -w doesn't exist. Create it? - Stack Overflow

So it seems like WinScp is sending some extra information to the command line for Notepad++ to open.

PostNew postRe: current local directory\411 doesn't exist. Create it?

Here is some logging:

. 2016-11-15 11:02:14.966 Startup conversation with host finished.
. 2016-11-15 11:02:23.344 Copying 1 files/directories to local directory "C:\Users\j.bos\AppData\Local\Temp\scp02221\aix-inet24-001%2Funipaas@aix-inet24-001.mover.local\inet24\nl\temp\"
. 2016-11-15 11:02:23.344 PrTime: Yes; PrRO: No; Rght: rwxrwxr-x; PrR: No (No); FnCs: N; RIC: 0100; Resume: S (102400); CalcS: Yes; Mask:
. 2016-11-15 11:02:23.344 TM: A; ClAr: No; RemEOF: No; RemBOM: No; CPS: 0; NewerOnly: No; InclM: ; ResumeL: 0
. 2016-11-15 11:02:23.344 AscM: *.*html; *.htm; *.txt; *.php; *.php3; *.cgi; *.c; *.cpp; *.h; *.pas; *.bas; *.tex; *.pl; .htaccess; *.xtml; *.css; *.cfg; *.ini; *.sh; *.xml;*.lng
. 2016-11-15 11:02:23.344 File: '/inet24/nl/temp/BLK00001010137914324.tmp' [2016-11-15T09:31:54.000Z] [999]
. 2016-11-15 11:02:23.346 Copying "/inet24/nl/temp/BLK00001010137914324.tmp" to local directory started.
. 2016-11-15 11:02:23.346 Ascii transfer mode selected.
. 2016-11-15 11:02:23.346 Opening remote file.
> 2016-11-15 11:02:23.346 Type: SSH_FXP_OPEN, Size: 57, Number: 2307
< 2016-11-15 11:02:23.346 Type: SSH_FXP_STATUS, Size: 24, Number: 2052
. 2016-11-15 11:02:23.346 Discarding reserved response
< 2016-11-15 11:02:23.347 Type: SSH_FXP_HANDLE, Size: 13, Number: 2307
> 2016-11-15 11:02:23.347 Type: SSH_FXP_FSTAT, Size: 13, Number: 2568
< 2016-11-15 11:02:23.349 Type: SSH_FXP_ATTRS, Size: 37, Number: 2568
> 2016-11-15 11:02:23.352 Type: SSH_FXP_READ, Size: 25, Number: 2821
< 2016-11-15 11:02:23.353 Status code: 1
. 2016-11-15 11:02:23.353 3 skipped SSH_FXP_WRITE, SSH_FXP_READ, SSH_FXP_DATA and SSH_FXP_STATUS packets.
> 2016-11-15 11:02:23.353 Type: SSH_FXP_CLOSE, Size: 13, Number: 3332
. 2016-11-15 11:02:23.354 Preserving timestamp [2016-11-15T09:31:54.000Z]
. 2016-11-15 11:02:23.357 Transfer done: '/inet24/nl/temp/BLK00001010137914324.tmp' [999]

New postRe: current local directory\411 doesn't exist. Create it?

Thank you for your answer.

In the attachments, you can see my preferences, action and Notepad++ message.


Jeroen Bos

Re: current local directory\411 doesn't exist. Create it?

Can you post a screenshot of the message?

Just a wild guess: Doesn't you have this directory misconfigured here?

(Solved) current local directory\411 doesn't exist. Create it?


Every time I open a file in Notepad++ from the remotedirectory in WinScp, I get the message "current local directory\411 doesn't exist. Create it?"

- Why does WinScp this file to be there and what is the purpose of it?
- Is there maybe a possibility for not needing this file?


Jeroen Bos