Post a reply

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)


Topic review


Re: 502 Command not implemented

Yes they are automatic.

Re: 502 Command not implemented

I tested with CuteFTP and FileZilla today. They all error in similar fashion.

Only difference being with CuteFTP, under Global Preferences, you can tell it not to perform a PWD.
Unfortunately, it only errors again but this time on when the LIST command is used.

Can usage of the PWD and LIST commands be disabled on WINSCP? Or are these commands built in (automatically issued) as part of normal session establishment?

Re: 502 Command not implemented

If you server does not support the PWD command, you cannot use WinSCP to connect to ti, unfortunately.
Were you able to use any other FTP client? I believe that most GUI clients will have the same requirement.

502 Command not implemented


I am trying to connect to a remote FTP host (not under my control) using FTP with TLS/SSL Explicit encryption with a signed client certificate.

I get connected, certificate handshake takes place, I receive welcome message and session is started. I beleive once the PWD command is issued the host throws multiple errors retrying...

The following error is displayed..
"Error getting name of current remote directory
Command Not Implemented"

I've tried enabling and disabling Passive connectivity. I received the same errors.

My log file is attached.

Any assistance would be greatly appreciated.