Post a reply

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)


Topic review


Thank you very much, Martin!
After setting the putty path correctly it works perfectly fine!

Re: WinSCP does not start after wrong putty path

Thanks for your report.

This issue has been added to the tracker:

To reset the PuTTY path, run WinSCP once like this:

winscp.exe /rawconfig Interface\PuttyPath=

WinSCP does not start after wrong putty path


I installed WinSCP 5.9.3 correctly (Windows 8.1). After that I changed the path to putty and added an "-X" (using Preferences->Application) but I did a mistake; it seems that I deleted the "exe" of "putty.exe" and, perhaps, also went wrong with quotation marks.

However, if I now try to start WinSCP the following error message (in German - I translated it) occurs with the button "OK" and "Help". Independent of the button I press WinSCP does not start. The program only closes. So, I am not able to correct the wrong path to putty. This is the error message:

Error - WinSCP
invalid command '"C:\Program Files\putty\putty.-X'.

In addition, uninstalling WinSCP does not help! That is weird! Even during the uninstall routine the above error message occurs. It seems that WinSCP is not fully uninstalled but all files and directories are deleted as far as I can see. Same error message occurs during the install routine after uninstalling. That's why I guess it's not uninstalled fully. I am still not able to open the program or uninstall and re-install it in a clean version.

Thanks for help!