Post a reply

Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)


Topic review


Re: Error Registering 32 Bit Assembly

On 64-bit systems, the c:\windows\system32 is a magic folder that cannot be access by 32-bit applications.

Well I'll reply to my own. I got it resolved. I moved the file from the c:\windows\system32 folder into c:\windows\syswow64 and registered it with it there and it had no issues.

Error Registering 32 Bit Assembly

When I attempt to register the 32 bit option I get the error message:

RegAsm : error RA0000 : Unable to locate input assembly 'c:\windows\system32\WinSCPnet.dll' or one of its dependencies.

The command I run is:

%WINDIR%\Microsoft.NET\Framework\v2.0.50727\RegAsm.exe c:\windows\system32\WinSCPnet.dll /codebase /tlb:WinSCPnet32.tlb

But when I do the 64 bit version, it works properly:

%WINDIR%\Microsoft.NET\Framework64\v2.0.50727\RegAsm.exe c:\windows\system32\WinSCPnet.dll /codebase /tlb:WinSCPnet64.tlb

This is on an older server (windows Server 2003 R2) but 2 other servers it worked. I did just notice that the one not working is x64 Edition. Could that be it and any ideas?

Thanks very much in advance.