Post a reply

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)


Topic review


Ok thanks !

"+" replaced by " " on URL when running from CLI


First, I'd like to thank you this great tools I use everyday !

When WinSCP is launched from or WinSCP.exe CLI, if a "+" is contained in the full URL (especially on username), it is replaced by a " " and authentication fails:

Here is an exemple with a Cygwin SSH Server (FYI: it's in french):
C:\Program Files (x86)\WinSCP> sftp://DOMAIN+USER:PASSWORD@SERVER.FQDN
Ouvrir une session en utilisant un paramètre de la ligne de commande est déprécié. Utilisez la commande 'open' à la place.
Recherche de l'hôte... (Searching for host)
Connexion à l'hôte... (Connecting to host)
Authentification... (Authentication)
Utilisation du nom d'utilisateur "DOMAIN USER". (Using the Username DOMAIN USER -Without '+' !-)
Authentification avec le mot de passe pré-entré. (Authentication with given password)
Accès refusé. (Access Denied)
Déconnexion inattendue Résultat de la commande exit sur le serveur 0 (Unexpected disconnection...)
Log d'authentification (voir le log de session pour les détails) (See log for more details)
Utilisation du nom d'utilisateur "DOMAIN USER". (Using username "DOMAIN USER")
Accès refusé. (Access Denied)

Erreur d'authentification (Authentication failure)

With WinSCP.exe, exact same issue.

I tried to escape + and various other workaround but without success.

WinSCP Version: 5.9.4 (Tried with recent but older version: same issue to)
OS: Windows 10 x64 Enterprise
-u argument used with cmd.exe doesn't change anything.

Hope this helps !