Post a reply

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)


Topic review


Re: Timeout detected. (control connection) - Copying files to remote side failed

The kernel of our server has just been updated, and although I have not really had chance to really test it the timeout problem seems to have gone away.

The previous version was:
Red Hat Enterprise Linux Server release 6.7 (Santiago)
Kernel 2.6.32-573.el6.x86_64 on an x86_64

Version now:
Red Hat Enterprise Linux Server release 6.7 (Santiago)
Kernel 2.6.32-754.el6.x86_64 on an x86_64

It may be that it is in a good phase at the moment, but if the Linux/Kernel version was the cause then hope you find this information useful.

(originally sent by OP to the Admin by email)

Email sent.

Re: Timeout detected. (control connection) - Copying files to remote side failed

Thanks for your report.

Can you send me an email, so I can send you back a debug version of WinSCP to track the problem? Please include link back to this topic in your email. Also note in this topic that you have sent the email. Thanks.

You will find my address (if you log in) in my forum profile.


Despite the last few days working - and fine earlier in the day - encountered problem again with Passive mode disabled. Transferring two files, the first was okay and the problem happened about a quarter of the way for the second. Countless reconnecting and trying again no joy, and had to use Core FTP LE.

It appears that at certain times something is happening that causes a problem for WinSCP but cannot see what it is.

For reference, the final part of the log to show differences for not using Passive mode:

> 2017-05-04 14:15:29.697 TYPE A

< 2017-05-04 14:15:29.712 200 Switching to ASCII mode.
> 2017-05-04 14:15:29.713 PORT 10,0,208,136,248,13
< 2017-05-04 14:15:29.728 200 PORT command successful. Consider using PASV.
> 2017-05-04 14:15:29.729 STOR xxxxxxxxxx.txt
. 2017-05-04 14:15:44.506 Timeout detected. (data connection)
. 2017-05-04 14:15:44.507 Copying files to remote side failed.
. 2017-05-04 14:15:44.508 Connection was lost, asking what to do.
. 2017-05-04 14:15:44.508 Asking user:
. 2017-05-04 14:15:44.508 Lost connection. ("Timeout detected. (data connection)","Copying files to remote side failed.")
* 2017-05-04 14:15:45.510 (ESshFatal) **Lost connection.**
* 2017-05-04 14:15:45.510 Timeout detected. (data connection)
* 2017-05-04 14:15:45.510 Copying files to remote side failed.

Thanks dma_k, disabling passive mode looks to have solved it. Did a bit of test copying and problem never surfaced. Thanks again.

Seems to be similar to what I have reported earlier. Should be fixed in WinSCP v5.10. As a temporary workaround try to disable passive mode ("Advanced" button → "Connection" tree item → "Passive mode" checkbox).

Timeout detected. (control connection) - Copying files to remote side failed

I am been using Core FTP LE for ftp file transfers and have just discovered WinSCP. WinSCP is a far nicer program, but unfortunately on occasions get “Timeout detected. (control connection) - Copying files to remote side failed.” errors when copying files to the remote server.

Everything else works okay and problem only appears to be the copying of files that cause a problem. There is just no definitive pattern as sometimes it works and other times it does not. It does not matter if the files are small or large, ASCII or binary or copying to different directories, one day is fine and another is not. Tried adjusting the settings but still the same.

Core FTP always works and has never suffered from timeout problems.

Logs for both in attached ftplogs.txt.