Post a reply

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)


Topic review


Re: thanks that worked

@charlwillia6: It does not have to be SCP. It works for SFTP too, but the settings are different. Please read the FAQ:

Re: thanks that worked

@schuess: Thanks for this. I didn't see that it had to be SCP. This helped.

set the correct file ownership and permissions:

sudo chown -Rf ec2-user /var/www/mysite/location 
sudo chmod -Rf 755 /var/www/mysite/location

thanks that worked

@Gest: Thanks a lot. Got it to work. The FAQ was not that specific...

Im running Ubuntu 17.04. When you make a new session select SCP protocol and click on Advanced Settings. Then select SCP/Shell and write: /bin/bash -c "sudo -s"

On the server I have openssh installed.

I have my user, e.g.: webdev added to the sudo group
And I had to add to /etc/sudoers the line:

So after hours of trying it finally works...

And now for file listings as root

This thread is about the Terminal window (Ctrl+T).

Let's talk about the core function of WinSCP instead:
I also needed access to directories like /root and /var/lib/mysql. After some tinkering with the settings I figured out that for Debian and Ubuntu, I have to open the Login > Advanced window, navigate to the SFTP tree item and type sudo /usr/lib/openssh/sftp-server in the SFTP server box. This allowed me to use my non-root credentials to gain root access.

My apologies @martin. That worked flawlessly. Thank you.
WinSCP is a great tool b/t/w, thanks for the generous contribution.

You cannot use sudo from terminal. You need to specify it as "Shell" for the session. Please read the FAQ again.

Guess I'll pick it up where he left off:

same issue, read the faq, using WinSCP 3.8.2, here's my log:
. 2006-09-25 12:28:05.843 Startup conversation with host finished.
. 2006-09-25 12:28:17.000 Executing user defined command.
> 2006-09-25 12:28:17.000 sudo su ; echo "WinSCP: this is end-of-file:$?"
. 2006-09-25 12:28:32.001 Waiting for data timed out, asking user what to do.
. 2006-09-25 12:28:32.001 Asking user:
. 2006-09-25 12:28:32.001 Host has not answered for 15 seconds.
. 2006-09-25 12:28:32.001
. 2006-09-25 12:28:32.001 Wait for another 15 seconds? Pressing 'Abort' button will close session. ()
. 2006-09-25 12:28:38.361 Attempt to close connection due to fatal exception:
* 2006-09-25 12:28:38.361 Terminated by user.
. 2006-09-25 12:28:38.361 Closing connection.
* 2006-09-25 12:28:38.361 (ESshFatal) Terminated by user.

FWIW I'm on Ubuntu 6.06, my sudoers looks like so:
myusername ALL=NOPASSWD: ALL

I am not prompted for a password from the console/putty when I do a sudo su.


Please post a log file.

Yes, I just did it again and PuTTY works fine and without prompting. I just can't do it in WinSCP.

Can you try to login using PuTTY and specify /bin/bash -c 'sudo su -' as "Remote command" (on SSH tab)? Would it connect automatically without any prompt? Or post a log file.

Thank you for the response. I still can't get it to work. I edited the /etc/sudoers and added in the user account as it suggested and now I can do an sudo su and it switches me to root with no prompting for password. But I still can't get it to work within WinSCP. It just times out.

Re: Can you SU to root from a regular user in WinSCP somehow?

Please read FAQ

Can you SU to root from a regular user in WinSCP somehow?

I know generally you can't execute commands that require input (root password) but I was wondering if there was any way to pull this off?