Post a reply

Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)


Topic review


Re: 50mb file fails to transfer via script only

Can you upload the file in WinSCP GUI?
Can you attach a verbose FileZilla log file?

50mb file fails to transfer via script only

I have a script setup that transfers a specific file once a day from one server to another using SFTP. When I run the script the transfer doesn't appear to start. The progress never moves past 0% and after 15 seconds it gives me an error about the server not responding. I have connected to the same server using the same credentials in FileZilla and the file transfers just fine with no issues.

My connection string uses "-rawsettings SendBuf=0" after reading another post but I get the same results with and without it. The only option I use is "option batch abort" but I also used continue and received the same response. No other commands besides a simple "put" statement are used.

Here is, what I believe to be, the portion from my log file that would help resolve this:

> 2017-10-04 13:25:32.572 Script: put c:\sql\REDACTED-export-20171004.usv
< 2017-10-04 13:25:32.573 Script: Using configured transfer settings different from factory defaults.
. 2017-10-04 13:25:32.575 Copying 1 files/directories to remote directory "/" - total size: 51,480,982
. 2017-10-04 13:25:32.575 PrTime: Yes; PrRO: No; Rght: rw-r--r--; PrR: No (No); FnCs: N; RIC: 0100; Resume: S (102400); CalcS: No; Mask:
. 2017-10-04 13:25:32.575 TM: M; ClAr: No; RemEOF: No; RemBOM: No; CPS: 0; NewerOnly: No; InclM: ; ResumeL: 0
. 2017-10-04 13:25:32.575 AscM: *.*html; *.htm; *.txt; *.php; *.php3; *.cgi; *.c; *.cpp; *.h; *.pas; *.bas; *.tex; *.pl; *.js; .htaccess; *.xtml; *.css; *.cfg; *.ini; *.sh; *.xml
. 2017-10-04 13:25:32.575 File: 'c:\sql\REDACTED-export-20171004.usv' [2017-10-04T17:25:31.053Z] [51480982]
. 2017-10-04 13:25:32.576 Copying "c:\sql\REDACTED-export-20171004.usv" to remote directory started.
. 2017-10-04 13:25:32.576 Binary transfer mode selected.
. 2017-10-04 13:25:32.576 Checking existence of file.
> 2017-10-04 13:25:32.576 Type: SSH_FXP_LSTAT, Size: 46, Number: 263
< 2017-10-04 13:25:32.590 Type: SSH_FXP_STATUS, Size: 75, Number: 263
< 2017-10-04 13:25:32.590 Status code: 2
. 2017-10-04 13:25:32.590 Checking existence of partially transferred file.
> 2017-10-04 13:25:32.590 Type: SSH_FXP_LSTAT, Size: 55, Number: 519
< 2017-10-04 13:25:32.605 Type: SSH_FXP_STATUS, Size: 84, Number: 519
< 2017-10-04 13:25:32.605 Status code: 2
. 2017-10-04 13:25:32.605 Opening remote file.
> 2017-10-04 13:25:32.605 Type: SSH_FXP_OPEN, Size: 68, Number: 771
< 2017-10-04 13:25:32.620 Type: SSH_FXP_HANDLE, Size: 64, Number: 771
> 2017-10-04 13:25:32.620 Type: SSH_FXP_WRITE, Size: 32844, Number: 1286
. 2017-10-04 13:25:47.641 Waiting for dispatching send buffer timed out, asking user what to do.
. 2017-10-04 13:25:47.641 Asking user:
. 2017-10-04 13:25:47.641 **Host is not communicating for 15 seconds.

Also worth noting, there is plenty of space on the server and the user account does not high a file size limit or any other restrictive properties. As I said, the transfer of the same file worked flawlessly in FileZilla.

I use WinSCP scripts for a large number of tasks and this is the first time I've had any problem at all. I would greatly appreciate any and all help with this!