Post a reply

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)


Topic review


Actually, on Windows 7, you may have a "Raster fonts" selected as the default in console windows. Make sure you select "Consolas" or "Lucida Console" instead.

OK, but where do you put/type that command-line?

This bug with "keyboard" has been added to the tracker:

Thanks for your report.

Can you send me an email, so I can send you back a development version of WinSCP for testing? Please include link back to this topic in your email. Also note in this topic that you have sent the email. Thanks.

You will find my address (if you log in) in my forum profile.

I tried the latest 5.11.2 and some older versions around 5.5

Usually I run via command-file /script=winscpscript.txt

Printing commands directly in produces the same result.

There is something with russian transalation or character encoding.
I have Win7 Pro russian.
I tried to set default codepage for non-unicode programs to engish and to russian. It didn't help.
The outuput changed from "iaie?eou iiaee??aiea e iaecaanoiiio na?aa?" to "????????" but keyboard still didn't work.

Thanks for your report.
What version of WinSCP are you using?
How exactly are you running


Win7 is russian. Unreadable text is in russian, and it asks to press "Д" for Yes, but pressing Д,д,Y,y or any other key except "esc" doesn't do anything.
I reinstalled winscp without transaltion. All text now is in english. Winsp asks to confirm host key and pressing "y" works.
Xeenych fails

On a newly installed Win7 Pro I run with the following: /script=winscpscript.txt

# Automatically abort script on errors
option batch abort
# Disable overwrite confirmations that conflict with the previous
option confirm off
# Connect to FTP server using a password
open sftp://user:pass@ -rawsettings ProxyMethod=2 ProxyHost= ProxyPort=9050
# Upload file
cd /var/www/map/
put -delete 03-Osme\*.* /var/www/map/
# Disconnect

This worked perfectly before I reinstalled Win7 to corprate version. produces the following (looks like stack overflow):

D:\10 - mapexport>echo off
batch abort
reconnecttime 120
confirm off
Euo na?aa?Е
Ioeaea naoe: niaaeiaiea n "" ioeeiiaii.
batch abort
reconnecttime 120
confirm off
Euo na?aa?Е
Niaaeiy?nu n na?aa?iiЕ
I?iaie?eou iiaee??aiea e iaecaanoiiio na?aa?o e aiaaaeou aai ee?? a eyo?
Ee?? oinoa na?aa?a ia iaeaai a eyoa. Iaeucy aa?aioe?iaaou, ?oi yoi oio naiue na?
aa?, eioi?ue aai io?ai.
Ioia?aoie ee??a na?aa?a ssh-ed25519:
ssh-ed25519 256 e8:5b:37:b8:61:dc:81:5a:3a:f9:4a:da:79:83:5b:cf
Anee au aiaa?yaoa yoiio oinoo, ia?ieoa лAa╗. Aey iiaee??aiey aac aiaaaeaiey ee??
a oinoa a eyo ia?ieoa лIao╗. ?oiau i?a?aaou iiaee??aiea, ia?ieoa лIoiaia╗.
In scripting, you should use a -hostkey switch to configure the expected host ke
(A)a, (I)ao, (I)oiaia (0 n), (E)iie?iaaou ee??: Ioiaia
Ee?? na?aa?a ia i?iaa?yeny!
Ioia?aoie ee??a oinoa Ч ssh-ed25519 256 e8:5b:37:b8:61:dc:81:5a:3a:f9:4a:da:79:8