Post a reply

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Options
Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)

Options

Topic review

martin

Re: Some uploads never finish

Thanks for your report.

Can you send me an email, so I can send you back a debug version of WinSCP to track the problem? Please include link back to this topic in your email. Also note in this topic that you have sent the email. Thanks.

You will find my address (if you log in) in my forum profile.
thor61

Re: Some uploads never finish

martin wrote:

I hope that I have fixed this one too already :-)


It seems this bug ist persistent since 10 years :-/

I tried to transfer about 83GB in 140.000 files. After all files were transfered without any loss (verified on target system), the queue keeps one line with 100% progress and remaining time 0:00:00. Below this line there were many empty lines with waiting in the progress column. In this state, winscp itself consumes about 50% of cpu performance, but nothing else happens.

thx for any hints.

winscp 5.11.3 build 7995 on windows server 2016 build 1607
martin

Re: Some uploads never finish

I hope that I have fixed this one too already :-)
sopi20

Some uploads never finish

Hi Martin,

I'm experiencing a little bug (at least I think it is one) in the new 4.0 version - I am working with winscp in a way, that i open some .php files, edit then, switch to firefox to check whether it works, switch back, edit, etc. I always save after any change the document (I benefit from the fact, that it is instantly uploaded back to the server any time I save it). The problem that as from 4.0 I notice, that sometimes a file gets upload (100% status), bude it is not removed from the queue and stays there forever... then I right-click on that file and try to cancel or suspend the transfer (although it is finished already, I can see it on the server), nothing happens.

Any idea what should be the problem or how to debug this ? The annoying fact is, that if this happens, I cannot edit the same file anymore.... even when I close the file in editor and open in one more time - I have to close winscp with all the files (sometimes I have 20 opened files in one time) and reconnect and open all the times and start working again.

So.... any ideas ?

Thanks for any answer Martin....

P.S.: I am connecting via sftp to a freebsd server with openssh 0.9.8 if this can help in any way.