Post a reply

Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)


Topic review


Re: Unknown command 'cp'

As documented:
Unsupported by most SFTP servers. The server has to support SFTP extension copy-file (supported by ProFTPD/mod_sftp for example).

Re: Unknown command 'cp'

martin wrote:

cp command is supported since the 5.12 beta only.

I've forgot to mention that in documentation. It's corrected now:

Thanks Martin for the quick response.

I've now downloaded and installed the 5.12 beta release. Upon testing, am now getting the following error:

"Operation not supported."

Have tried the following (where "backup" is a sub-directory of where I currently am) all with the same error:

cp static.db /backup/
cp static.db backup/
cp static.db /backup

The server is "Red Hat Enterprise Linux Server release 6.5 (Santiago)".

Am I doing something wrong?

Thanks, Tim.

Unknown command 'cp'

Hi team,

Am receiving an "Unknown command 'cp'" message when attempting the following: /command "open sftp://ks:password@" "cp *.db /backup/" "close" "exit"

The online help lists 'cp' as a usable command, yet when type 'help' in the Command console, it's not listed.

I'm running the latest v5.11.

Any help on this would be greatly appreciated!