Post a reply

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)


Topic review


Re: PUT "failed" on Server 2012

Response sent by email:

It turns out that the problem was on the CoreFTP Server side. I call a script upon upload that was in the wrong directory. Since the script wasn't found, the server failed the PUT operation, which WinSCP reported correctly. When I fixed the script path, it worked again.

Re: PUT "failed" on Server 2012

Please attach a full session log file from both systems (using the latest version of WinSCP).

To generate the session log file, use /log=path_to_log_file command-line argument. Submit the log with your post as an attachment. Note that passwords and passphrases not stored in the log. You may want to remove other data you consider sensitive though, such as host names, IP addresses, account names or file names (unless they are relevant to the problem). If you do not want to post the log publicly, you can mark the attachment as private.

If you have problems attaching the logs, upload them elsewhere and post a link.

PUT "failed" on Server 2012

I tried to post with log attachment, but it didn't stick.

I have a Powershell script (5.0) using WinSCP assembly. The server is CoreFTP. A PUT works on Windows 7 32-bit, but fails on Server 2012 64-bit. Oddly, the small file gets put correctly (size, content), but then the return code is bad and CoreFTP's follow up execution does not happen. So the file is there but it reports as failed.

Any idea what it could be? Or how I could narrow it down? The WinSCP session log reports the input file as not existing, even though it clearly exists and the data gets transferred.

Wolfgang G. Propfe