Post a reply

Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)


Topic review


WINSCP can't find host on command line

I have an unusual problem.
I have a batch file that is executed as follows:
C:\Progra~2\WinSCP\ /script=d:\apps_to_compile\cff\winscp.txt

When I run the batch file from either Windows or the Command Prompt, it executes perfectly.
However, when I run the batch file from a SQL Server job using the command processor utility, I get the following in the (debug level 2) log:
D:\apps_to_compile\cff>C:\Progra~2\WinSCP\ /script=d:\apps_to_compile\cff\winscp.txt
Searching for host...
Host "CCS_DEV_SERVER" does not exist.

The script looks like this:

call site lrecl=900 blksize=27900 recfm=fb cy pri=10
put -transfer=binary D:\out.fil '"CCS.G.IN(+1)"'
I acknowledge that this might be a permissions issue, but to solve that problem, I need to know where, exactly, are these sites stored? Why can't WINSCP find it's own data?