Post a reply

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Options
Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)

Options

Topic review

matesstar

Re: I'm having the same problem where the connect through SSH tunnel stopped working after an update

dteller wrote:

I've tried versions 5.15, 5.15.1 and 5.13.9
Windows 10 version 1809 build 17763.437
...

For me there were some versions working and some not working. I am not sure if it was caused by Windows version or WinSCP version. In actual combination it works (WinSCP 5.15.4, Windows 10 1809 build 17763.805)
Guest

Re: I'm having the same problem where the connect through SSH tunnel stopped working after an update

dteller wrote:

I've tried versions 5.15, 5.15.1 and 5.13.9
Windows 10 version 1809 build 17763.437

The error is
Cannot find free local listening port number for tunnel in range 50000 to 50099.

When I look in TCPView, there aren't actually any ports used in that range.

If I set the port manually to 49999 (which is free) I get
Network error: Connection "127.0.0.1" refused.

I also tried running it as an administrator.

If I manually set the port to 51000 it works.

Manually set the port to 51000 it works.
If hit "SSH warring: Authorized users only. All activity may be monitored and reported " press continue next!
Saksham

Cannot find free local listening port number for tunnel in range 50000-50099

Hey,

I started getting this problem after updating my windows version to 1809.
The solutions listed here involve manually changing the port. How can I do that?
And is there no better solution to this?

Thanks
martin

Re: I'm having the same problem where the connect through SSH tunnel stopped working after an update

Thanks for your report.
I have sent you an email with a debug version of WinSCP to the address you have used to register on this forum.
dteller

I'm having the same problem where the connect through SSH tunnel stopped working after an update

I've tried versions 5.15, 5.15.1 and 5.13.9
Windows 10 version 1809 build 17763.437

The error is
Cannot find free local listening port number for tunnel in range 50000 to 50099.

When I look in TCPView, there aren't actually any ports used in that range.

If I set the port manually to 49999 (which is free) I get
Network error: Connection "127.0.0.1" refused.

I also tried running it as an administrator.

If I manually set the port to 51000 it works.
martin

Re: Same problem

curvers wrote:

Same problem here using latest WinSCP version 5.15.1
windows:
OS Name Microsoft Windows 10 Pro
Version 10.0.17763 Build 17763

i did not have the problem before,
few days ago I upgraded from windows home to windows pro, so maybe its related to this issue

Thanks for your report.
For me it works fine with the same setup.

Anyway, I have sent you an email with a debug version of WinSCP to the address you have used to register on this forum.
curvers

Same problem

Same problem here using latest WinSCP version 5.15.1
windows:
OS Name Microsoft Windows 10 Pro
Version 10.0.17763 Build 17763

i did not have the problem before,
few days ago I upgraded from windows home to windows pro, so maybe its related to this issue
martin

Re: Still exists (5.13.8)

eactors wrote:

I still have the same problem running 5.13.8.
The problem was gone some times and is back now. I tried a full reboot of windows 10 but it did not help (shutdown /g /f /t 0).

Can you send me an email, so I can send you back a debug version of WinSCP to track the problem? Please include link back to this topic in your email. Also note in this topic that you have sent the email. Thanks.

You will find my address (if you log in) in my forum profile.
eactors

Still exists (5.13.8)

I still have the same problem running 5.13.8.
The problem was gone some times and is back now. I tried a full reboot of windows 10 but it did not help (shutdown /g /f /t 0).
matesstar

Solution

For me, update to winscp 5.13.7 helped.
martin

ApolloX wrote:

I'm having the exact same problem. Have had to manually go into each connection and set a random port for the past month or so.

Thanks for your report.

Can you send me an email, so I can send you back a debug version of WinSCP to track the problem? Please include link back to this topic in your email. Also note in this topic that you have sent the email. Thanks.

You will find my address (if you log in) in my forum profile.
ApolloX

Changing the port range in Windows worked. Kind of a pain but at least it's gone.
ApolloX

I'm having the exact same problem. Have had to manually go into each connection and set a random port for the past month or so.
martin

Re: I'm too

Thanks for your report.

Can you send me an email, so I can send you back a debug version of WinSCP to track the problem? Please include link back to this topic in your email. Also note in this topic that you have sent the email. Thanks.

You will find my address (if you log in) in my forum profile.
Liam

I'm too

See attached screenshot
supergarry

Re: WinScp's "Connect through SSH tunnel" feature stopped working after Windows 10 1809 update

Unfortunately I didn't save session log before rolling back to 1803.
But I remember when I selected some port (ex. 50002) it said something similar to: "Can't connect to 127.0.0.1"
martin

Re: WinScp's "Connect through SSH tunnel" feature stopped working after Windows 10 1809 update

It works for me.

Can you post a session log file?

Does it work, if you select another local port in session settings?
https://winscp.net/eng/docs/ui_login_tunnel
supergarry

WinScp's "Connect through SSH tunnel" feature stopped working after Windows 10 1809 update

Hello,
WinScp's "Connect through SSH tunnel" feature stopped working after Windows 10 1809 update.
It says: "cannot find free local listening port number for tunnel in range 50000 to 50099"
I rolled back to 1803 version and WinSCP works again.

Best regards,
Igor