Post a reply

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)


Topic review


Re: BugReport: "Control '' has no parent window"

Thanks for your report. Sorry, your attachment got lost. Can you please re-post it?

BugReport: "Control '' has no parent window"

Firstly, sorry for unconcise report.. And I'm quite convinced that this issue is more likely to be the problem of hardware because blue screen just started to happen more frequently with this same issue, and I guess it's triggered by me swapping SSD.

I was getting a few crashes for no apparent reason (sorry I wasn't checking logs at the time and there were no indication of what had happened for me as it just abruptly crashed without any notification). Then I updated to new WinSCP. After a night, I was seeing it showing popup saying it had to shutdown for some weird reason, followed by blue-screen that indicates that there are some driver-related issue. Popup's message has changed to the subject's like "Control '' has no parent window", and this time it just keeps on coming up when I attempt to close that popup. I don't know why but now it just crashes every single time I attempt to connect to the server (with configuration that has been problematic since before this time: which is the reason I was testing for the half year: I configure the FTP server, but I got the report that WinSCP won't work from WinSCP in certain network. I have no clue if it is connected with this issue, but their log shows that. Here's the last trace log for them.)
. 2018-07-23 13:50:47.179 に接続しました。SSL 接続を準備しています...
< 2018-07-23 13:50:47.179 220 (vsFTPd 2.2.2)
> 2018-07-23 13:50:47.179 AUTH TLS
< 2018-07-23 13:50:47.179 234 Proceed with negotiation.
. 2018-07-23 13:51:02.726 タイムアウトしました。 (コントロール用接続)
. 2018-07-23 13:51:02.726 接続に失敗しました。
. 2018-07-23 13:51:02.726 Got reply 1004 to the command 1
* 2018-07-23 13:51:02.757 (EFatal) 接続に失敗しました。
* 2018-07-23 13:51:02.757 タイムアウトしました。 (コントロール用接続)
* 2018-07-23 13:51:02.757 接続に失敗しました。

1. Perhaps this is the cause for the reason I mention later? I cloned my system (Windows 10) to the new SSD (which had some older version of WinSCP). On the course of installation, I was rigorously removing file here and there in C drive (uninstalling application, many folders in user's appData directory, even some Program Files things.)
2. WinSCP got updated to "5.13.7 (Build 9125) (OS 10.0.17134 - Windows 10 Home)"
3. I was fiddling with FTP server & firewall with the client PC logged into VPN. This has been tested a few times before on the same PC (even after upgrading SSD, like yesterday. It was just working as I was expected). Then I noticed WinSCP was gone (shut down) while I was away sending files, like some sort of crash happened without any prompt. Later, I was getting error prompt saying something like "unusual crash/shutdown" without much information. (I don't have a log for this time.)
4. a few moments later I got blue screen (Seemingly one that relates to drivers. And the only hardware that had modification in the last few years in the stable PC was the recent SSD a few days ago.
5. Rebooted. Went to device manager and tried to update the driver for the new disk, but it says the necessary driver has already been applied, so nothing has changed.
6. Then this error came out. Checked the log file, nothing much there. I tried to recreate the situation, so I exited WinSCP once and restarted it. (OS is still up.) I tried to connect to this one site that I was keep on connecting (which connects just fine). But the same popup shows up forever even if I press down on [OK], which wasn't the case before. It seemed as though only adds some more lines in the box part inside the error popup. The content after this report. And I put the log file (edited some part, mainly recursive ones like "Session upkeep"). Alt + F4 didn't work neither to proceed to the next step, so I just killed the process from task manager.
7. WinSCP starts, but then when I tried to connect, it just goes crashing. here's the last trace on that log:
< 2019-02-27 13:29:50.722 234 Proceed with negotiation.
. 2019-02-27 13:29:51.922 サーバーはクライアント証明での認証を要求しています。
.. Then it got into blue screen again..

Anyways, here's the text from the error popup:
スタック トレース:
(0025A85C) Vcl::Controls::TWinControl::CreateWnd
(0025ADE2) Vcl::Controls::TWinControl::CreateHandle
(0025C708) Vcl::Controls::TWinControl::WMPaint
(00261AE1) Vcl::Controls::TCustomControl::WMPaint
(0025BD51) Vcl::Controls::TWinControl::WndProc
(0025B398) Vcl::Controls::TWinControl::MainWndProc
(0038109C) System::Classes::_18201
(0003AF19) USER32.dll
(000373E5) USER32.dll
(00036F85) USER32.dll
(000396D7) USER32.dll
(0006BD3B) ntdll.dll.KiUserCallbackDispatcher
(00036A7B) USER32.dll.DispatchMessageW

and log file (verbose): attached

If anything, please let me know to