Post a reply

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)


Topic review


Re: Unable to create directory with subdirectorys using sftp

It's as expected. In general, WinSCP can create one folder at a time only.

Unable to create directory with subdirectorys using sftp

i need to create paths with subdirectorys, with sftp protocol it returns an error:
WinSCP.SessionRemoteException: "Error creating folder '/home/pdf/2019/1'.
No such file or directory.

The path "/home/pdf" already exists, but the subpath "2019/1" does not exist
When i am creating every single subdirectory in one step, it works. there is no need for until i am using the ftp prototol instead of sftp.

i am using Version 5.13.7, testing down to 5.13.3 and there is allways the same error.

i also testet different sftp servers (Synology, FileZilla Server, Webhosted SFTP) with the same result

is it a bug?

greetings :)