Post a reply

Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)


Topic review


Re: Trouble with Powershell Script, authentication failed in error log.

The version of assembly (Version=, ...; Product: does not exist. You must have some custom build.

Make sure you use the official build of the latest version of the assembly and the same version of WinSCP.exe.

Trouble with Powershell Script, authentication failed in error log.

I have recently started having issues downloading files with a script we use. When I first logged into the Client after the issue I noticed the SSH Host Key had changed as I had to accept the new key. Now I can login to the client but when I try to use the script I get an error Authentication failed. I have updated the Key in the script but nothing is working. I also turned on the logging and notice the Key looks different in the client version vs the script version. The client list out the MD5 + the SHA-256 key where the script log only shows the MD5. The version are also different between the client and the automation files I have in the script directory. I tried to update the script automation files but when I did I got "Incompatible external console protocol version 7". I ran the registration command but didn't help.