Post a reply

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)


Topic review


Re: Server refuse to start a shell/command using script.

But do you have a shell access? Can you login to that server using any SSH terminal client like PuTTY? Are you really supposed to use SCP protocol? Did you try SFTP? (sftp://)

Server refuse to start a shell/command using script.


I'm trying to transfer/delete files from Unix remote server to Windows. The process is executed via an Automation using SSIS (executed from Execute Process Task box), so the source of execution is WindowsServer. Everything goes great until it gets to open a session via script batch(script.txt):


open scp://Unix_UserName:passUTF8HEXword@Unix.IP.Address.Number:Port -hostkey="ssh-rsa HostkeyNumber"
get -delete /UnixServerPath/File*.pdf \\WindowsServerPath\

My log says "Access granted" but then gives "Server refuse to start a shell/command" error. I attached my log and manual test via CMD for reference. The IT dept in charge of the UnixServer says they gave me permissions for read/write/delete/copy/move/etc. But I still get the same error. If someone can point me to the right direction I appreciate it because I've been reading the documentation/blogs and tried a lot of possible solutions for weeks with no luck.