Post a reply

Options
Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)

Options

Topic review

martin

Re: Solution that worked for me

disfunktedfish wrote:

I added those options to my script and it worked like a charm. Hopefully everyone else gets help with this down the line if they should have the same issue.

Thanks for sharing your solution.
Note that only this makes any difference:
$transferOptions.PreserveTimestamp = $False
disfunktedfish

Solution that worked for me

Hi All,

I found my issue and I'll post here for anyone to use this answer, hopefully at the very least it leads them in the right direction. My original issue is I was only moving one file at a time with this original configuration: https://winscp.net/eng/docs/script_local_move_after_successful_upload

The ending solution here, at the end where Stan.Gobien amends his transfersettings/upload settings is what ended up being the solution for me: https://winscp.net/forum/viewtopic.php?t=22619

#transferoptions

      $transferOptions = New-Object WinSCP.TransferOptions
      $transferOptions.FileMask = "*.*"
      $transferOptions.FilePermissions = $Null # This is default
      $transferOptions.PreserveTimestamp = $False     
     
     
        # Upload files, collect results
        $transferResult = $session.PutFiles(($localPath + "*.*"), ($remotePath + "*.*"), $False, $transferOptions)


I added those options to my script and it worked like a charm. Hopefully everyone else gets help with this down the line if they should have the same issue.
disfunktedfish

I am having the same issue described by previous gentlemen with the powershell transfer and move script found here: https://winscp.net/eng/docs/script_local_move_after_successful_upload

I don't deviate from the script above, I have my SFTP parameters in there and it will transfer one file and move it to the directory. It will only move one. Not sure what I need to do to make sure all of them get moved over.

Here is the log:
martin

Re: Same Issue

Anonymous wrote:

I am having the same issue. What is the answer?

The same answer:
Please attach a full session log file showing the problem (using the latest version of WinSCP).
Guest

Same Issue

I am having the same issue. What is the answer?

Thanks,
Jacob
martin

Re: Powershell to copy multiple files to SFTP server

Please attach a full session log file showing the problem (using the latest version of WinSCP).

To generate the session log file, set Session.SessionLogPath. Submit the log with your post as an attachment. Note that passwords and passphrases not stored in the log. You may want to remove other data you consider sensitive though, such as host names, IP addresses, account names or file names (unless they are relevant to the problem). If you do not want to post the log publicly, you can mark the attachment as private.
Userp

Powershell to copy multiple files to SFTP server

I am using the sample script found here at WinSCP to upload files in a local directory to a directory on an SFTP server, then move the local file. The Powershell script works, but only uploads one file to the SFTP directory at a time. I have to run the script multiple times to move all files. Not sure why that is. This is the script.

param (
    $localPath = "c:\ebanking\PosPay\*.*" ,
    $RemotePath = "/incoming/arp/" ,
    $backupPath = "C:\eBanking\Z_Arch\PosPay"
)
try
{
# Load WinSCP .NET assembly
Add-Type -Path "WinSCPnet.dll"
 
# Set up session options
$sessionOptions = New-Object WinSCP.SessionOptions -Property @{
    Protocol = [WinSCP.Protocol]::Sftp
    HostName = "fdqn.computer.com"
    UserName = "xxxxxxx"
    Password = "xxxxxxxxxxx"
    SshHostKeyFingerprint = "ssh-rsa 1024 abcdefghijklmnopqrstuvwxyz"
   
}
 
$session = New-Object WinSCP.Session
 
try
{
    # Connect
    $session.Open($sessionOptions)
 
        # Upload files, collect results
        $transferResult = $session.PutFiles($localPath, $remotePath)
 
        # Iterate over every transfer
        foreach ($transfer in $transferResult.Transfers)
        {
            # Success or error?
            if ($transfer.Error -eq $Null)
            {
                Write-Output "Upload of $($transfer.FileName) succeeded, moving to backup" >> C:\eBanking\Z_Logs\BofAPP.log
                # Upload succeeded, move source file to backup
                Move-Item $transfer.FileName $backupPath
            }
            else
            {
                Write-Host "Upload of $($transfer.FileName) failed: $($transfer.Error.Message)"
            }
        }
    }
    finally
    {
        # Disconnect, clean up
        $session.Dispose()
    }
 
    exit 0
}
catch
{
    Write-Host "Error: $($_.Exception.Message)"
    exit 1
}


Any ideas why not all the files on local directory are not moved?