Post a reply

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)


Topic review


My bad - I had accidentally misspelt my WinSCP session name with two "l"s instead of one in PuTTY. It works fine with the corrected name.

Sorry for the trouble.

If your session is in a folder, your PuTTY session name has to match WinSCP name, including the folder.

As it does not work even without the folder, I'm sending you an email with a debug version of WinSCP to the address you have used to register on this forum.

It copied '"C:\Program Files\PuTTY\putty.exe" -load "WinSCP temporary session"' to my clipboard. That's weird since I know for a fact that I have a configuration in Putty with the same name.

The session in WinSCP is in a folder, and I wasn't sure if the Putty configuration had to include the folder name as well. So I tried creating two Putty configurations with and without the folder name prefix. Neither worked.


Works for me with PuTTY 0.72 64-bit and WinSCP 5.15.3.

If you hold down Ctrl+Shift switch clicking the "Open Session in PuTTY" command, what does WinSCP copy to clipboard?

My Putty version is 0.70 (64-bit). But I tried updating to 0.72 (64-bit) and the issue still persists.

Specifically, I use the "Tunnels" feature to forward ports as soon as certain Putty sessions open.

Re: Saved settings don't load when launching putty

Thanks for your report.
Though I cannot reproduce that.
What version of PuTTY are you using? Is it 32-bit or 64-bit?

Saved settings don't load when launching putty

In version 5.15.3, launching putty from the UI doesn't load the putty configuration with the same name. It always loads the default configuration (i.e. the behavior when no name-matching config is found). This seems to be a regression (but I'm not sure which version the regression appeared exactly). It worked fine earlier this year.