Post a reply

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)


Topic review


Sorry, my fault... i should read and think more carefully. Anyway, many thx for helping

Dinduch wrote:

Yes, sure, thats enabled

But that's the problem. If has to be turned off (what is the default state). Otherwise WinSCP won't recognize that the file has changed.

Yes, sure, thats enabled, but it didnt upload the changed file. Since it works with other Applications, i assume, thats the fault of WinMerge. But didnt want to use a other Application. Maybe i use a wrong version? I use (according to the about panel)

Update 1: I have now downloaded a new version 2.16.4 from and installed this. But here i get the same result. I use the 64bit version.

Update 2: I have missinterpreted your post. I have now disabled your mentioned option and voila, its now uploaded. Im so stupid...sorry

I have 5.15.3 installed. If i use Notepad++ to edit a file and svae it, it gets indeed uploaded to the server. But not by comparing and editing with WInMerge.

I tried CompareIt3 after reading this forum. There it works. Edited files are saved on the server. But not with Winmerge. Or is there a maybe a special setting i must enable in Winmerge?

Re: WinSCP remote diff, not saved

Do you have the latest version of WinSCP?

WinSCP remote diff, not saved

Im trying to do a remote diff with WinSCP. After changing one or both of the files, im asked by WInSCP, if would like to save the changes. I accept with yes, but the sved changes are not saved to the remote files. Im using
"d:\Program Files\WinMerge\WinMergeU.exe" !&

to compare 2 remote files.

Is there anything i can do?