Post a reply

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)


Topic review


Thank you.

I cannot use debug and official versions simultaneously, so I'm using only the first one. I plan to use a debug version today as well and see if I can catch the problem.

However I can confirm that when I turn off the dark mode, I'm able again to open Preferences -> Editor -> Edit existing editor -> Browse. When I switch WinSCP back to the dark mode, it crashes once I hit this button. This problem can be easily reproduced using both versions of WinSCP. I attached a WinSCP log from the debug version. I opened WinSCP, navigated to the above mentioned button "Browse" and hit it.

I'm using Windows dark mode as well.

Lardpower wrote:

I couldn't reproduce this error today.

Not even with the official version?

I couldn't reproduce this error today. I'll update this ticket when I have it caught using a debug version.

Thank you.

Hello Martin,

Thank you for your quick reply.

I'll read these instructions and use a debug version today in order to catch the same issue and send you more information about it.

Then I'll try to turn off the dark mode and see if problem persists.


Re: WinSCP stuck if directory contains the files of some specific type

Thanks for your report.
I have sent you an email with a debug version of WinSCP to the address you have used to register on this forum.

Btw, I assume the problem is related to the dark mode. Can you check if the problem goes away, once you disable the dark mode?

It happened again, I'm attaching a session log.

I tried to install WinSCP from the Microsoft Store and now drag-n-drop from the outside apps works. However, the main problem still persists.

One new observation: WinSCP crashes when I click Options -> Preferences -> Editors -> Selecting Notepad++ -> Edit -> Click "Browse" button in "Edit editor" dialog window. WinSCP is just getting closed without any messages or notifications.


WinSCP stuck if directory contains the files of some specific type


I'll try to describe this situation. WinSCP got randomly stuck when I'm drag-n-dropping some files from remote to local panel or vice versa, or even just opening some local or remote folder. It happens a lot during the last month. If I forcibly closes WinSCP, it cannot launch properly (please see my screenshot).

The only remedy for me was to temporarily rename the last local directory, after that WinSCP can be launched again and I can even navigate into that local directory without any problems, so it's not the permanent problem with some file types which are currently unknown for me.

Last time WinSCP stuck and my usual trick with the renaming the local directory didn't work, so I tried to investigate what can cause such damage. I was able to located the line in my .ini config file that prevents WinSCP from the correct launching: it was section "[Configuration\Interface\Commander\LocalPanel]", parameter "LastPath".

I tried to located the problem file or group of such files splitting the whole files and folder by half and check if that half causes the problem, but eventually no files alone can cause the same problem. However, if I return all files to their original place within that problem directory, WinSCP cannot be opened again.

I'm storing everything in .ini file located in OneDrive Windows directory.

Also for some time I cannot perform drag-n-drop operations from outside folders to WinSCP and I couldn't find how to fix it. I tried to use fresh .ini file, launch WinSCP as administrator, use WinSCP portable, try to use "Download files via temporary folder" - no result. Maybe it's somehow related to the problem.

I'm using:
WinSCP 5.15.4 (Build 9849)
Windows 10.0.18362 64-bit

I also would like to include some log, but this problem is probably not about some session, so I thinks any session log will be useless.

Thank you so much for WinSCP and help with that case.