Post a reply

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)


Topic review


Hi Martin,

where do I find the log file?

Thank you

Please post a full log file.

Thank you for your reply and sorry for the delay!

The message is:
Host key fingerprint is ssh-rsa 2048 [...]
Authentication failed.

Thank you and best regards

Re: Problems with host key / SFTP

I do not have any explanation. I guess the server (or at least its host key) was actually changed, despite they claim otherwise.

What is the exact message you are getting? (the host key is public, no problem about posting it here).

Problems with host key / SFTP

Dear community,

I tried to connect to a clients ftp via SFTP (port 22) today but got the error message by winSCP that the host key from remote differs from the locally stored key.

The last login is a few month ago but the hoster said they didn't change the machine in the meantime (and I didn't get an error message back then). Fortunately they communicate the host key of the server and it is indeed the suggested key from the winSCP error message.

Sounds like there's no problem, but I would like to understand why winSCP - although obviously nothing changed - doesn't seem to have the right key. I tried to read out the key in an ini export to compare it to the current key but the keys are encrypted.

Any idea what could be the reason for this behaviour?

Thank you in advance