Post a reply

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)


Topic review


Thanks for sharing your findings.

Hey Martin thanks for your time.
I've found the issue and it's not related to WinSCP issues, it was my Editor. Encoding was set to system default, now I forced utf-8. Editor probably remembers the encodings of the files he has opened before. But since the temporarily downloaded files from WinSCP are new to the editor, he used default encodings on them.

Re: Temporarily downloaded file doesn't keep encoding

WinSCP does not modify encoding of the files anyhow.

I'm not really sure if I understand your problem. Files do not have any encoding information in general (with an exception of BOM marks). So phrases like "does not have utf-8 encoding set" and "on the server its utf-8" are rather unclear to me.

Can you document your problem with few screenshots?

Temporarily downloaded file doesn't keep encoding

When opening utf-8 encoded file straight from server both with internal or external editor, file content does not have utf-8 encoding set (on the server its utf-8).
I did set the UTF-8 for internal editor but that didn't fix this.
Downloading the file to local PC and then opening it is OK.
By inspecting the issue noticed that temporary downloaded file looses the info about encoding and it gets windows-1252.
I'm on Windows 10 platform and also in controlPanel->region->Administrative->Change system locale I have set the checkbox "Beta: Use Unicode UTF-8 for worldwide language support" but this didn't fix the issue.
My guesses are the problem might be when WinSCP fetches the file from the server to temp folder.
Thanks in advance.