Post a reply

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)


Topic review


Thank you for the quick reply. I updated to the latest version of WinSCP and disabled the 'Attempt GSSAPI authentication' setting using the GUI and the connection worked. I then added AuthGSSAPI=0 to the command line script we're using and that worked too. This was the only job of ours that was failing but it was also the only job of ours that connected to a server on the same network. Hopefully this helps someone else out there.

Thank you again for your help.

Re: Authentication Failed In New Version But Not Old Version

The logs do not look like from scripting (unless you have edited them).

Anyway, for the logged sessions, the difference is that the 5.5.6 session has "GSSAPI authentication" disabled, while 5.15.3 session does not.

That won't really explain why your script fails. For that we need to see a real (or full) scripting log.

Authentication Failed In New Version But Not Old Version

Current WinSCP Version:
Last Working WinSCP Version:
Windows Version: Windows Server 2012 R2
Transfer Protocol: SFTP
GUI or Scripting?: Both
Test Command: "C:\XXX\" /log="C:\XXX\Script.log" /ini=nul /command "open sftp://XXX:YYY@ZZZZ/ -hostkey=""ssh-rsa QQQ"" -rawsettings ConsiderDST=0" "ls" "exit"

We recently updated from version to and one of our SFTP jobs is failing with an Authentication Failed error. It fails using both the GUI and using the command-line scripts WinSCP generates. If we use the script WinSCP generates with the old WinSCP version, it works. Looking through the logs I can’t figure out why exactly it’s failing. Originally I thought it might have been a special character in the password so we changed the password to alphanumeric but still got the Authentication Failed error. We probably should have updated a little sooner… but any assistance you can provide would be much appreciated.