Post a reply

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)


Topic review


Re: winscp window fails to display

Thanks for the reply! That was the problem. I was able to remove the "ghost display" and WinSCP appeared.

I think I've chipped in twice before ... just did again.

Re: winscp window fails to display

It looks like WinSCP starts on another display, which you may have turned off.
If you go to Windows Start > Settings > System > Display, do you see multiple displays there?

You can also try to delete the following registry key:
[HKEY_CURRENT_USER\Software\Martin Prikryl\WinSCP 2\Configuration\Interface]

winscp window fails to display

I have not used WinScp for a month or so. Today I tried to run it and cannot use it at all. Below I list the problem and my attempts to solve it. I do not know how to generate a log file, and do not see any file in the WinSCP directory. SO I guess this is "useless" but I do not know what else to do.

Based on my attempts to get WinSCP to work (as it has for years and years) the only thing that I can think of is that a recent update to Windows 10 has broken WinSCP.

Some of the attempts are show in this screenshot video:

First, the WinSCP window opened partially off my display, but I could not maximize or move it to the display to work with it. I could click on the toolbar and see my list of sites. Clicking on one the "master password" dialog opened and accepted the password, but the window never appeared.

Using "alt-tab" I can see WinSCP preview boxes, but selecting them does not bring up the window. Using Win-tab no window shows up on the desktop.

I had to use TaskManager to kill the app. Restarting it I could see a "Update" window preview from the taskbar, but as before could not open any winscp window on the display.

Here are things I have tried to get around this (none of them worked):
-Restart my laptop
-Disconnect my laptop from external displays so only the internal screen is displaying
Attempt to install the update by downloading through a browser. This failed because the .exe file could not be overwritten
Uninstalled WinsSCP. Reinstalled current version. Still failed
Installed a previous version that I know used to work.
Cleared up space on my harddrive which was getting full.
Nothing changed.