Post a reply

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)


Topic review


OK, thanks for the information.

The editor doesn't matter. Tried it with Windows Notepad and Notepad++. It seems that Windows is not capable of using long paths in arguments (or in the Windows API when the program tries to open that file).

I have set
in my registry to 1. But this only leads to the effect, that double clicking the file will use
notepad.exe C:\Users\myusername\AppData\Local\Temp\scp32179\plugins\servlet\CONFLU~1\default\Global\LIV3DEV\LIV3DE~1\Products\WAREHO~1\WAREHO~1\TECHNI~1\PACKAG~1.IUM
as system call instead of the full path.

Re: Edit files with long paths

What external editor are you using? How exactly do you "open the file locally" to circumvent the problem?

As a workaround, you can turn off Append remote path to temporary path:

Edit files with long paths

Most of Windows still has problems with long file names. Even though WinSCP is able to download and show them in internal editor, it's not possible to use an external editor right now if the path name gets too long.

If I open the file locally, Windows is circumventing this by using

instead of
C:\Users\myusername\AppData\Local\Temp\scp32179\plugins\servlet\confluence\default\Global\LIV3DEV\LIv3 Development\Products\warehouseNAVIGATION\warehouseNAVIGATION MSP\Technical Specification%3A warehouseNAVIGATION MSP\Package.Sub.TruckCommunication.GetLoadSensorOrder.iuml

WinSCP is trying to open the editor using the full filename instead of the 8.3 formatted version which fails.

I'm using WebDAV with Confluence in this case and have therefore no influence on the length of the filenames and resulting paths.