Post a reply

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)


Topic review


But what problem do you get with WinSCP?

Here is the error I get when I ommit -t:
$ ssh /bin/bash

password: xxx
FS Error: ssh must be used with the -t option to enable PTY

Once again, PTY is mutually exclusive to SFTP/SCP protocols. In other words, no SFTP nor SCP client can ever work with a server that does not allow connections without a terminal emulation. It has nothing to do with WinSCP.

If you want us to help you further, please provide more details than "it does not work".

"Why do you need PTY to connect?"
I tried to connect to the server with putty and without '-t', but it does not work. The option -t is mandatory for this server.
No chance to add this option in WinSCP ? Or do you know an alternative ?

Re: Enable PTY ?

PTY is mutually exclusive to SFTP/SCP protocols.
Why do you need PTY to connect?

Enable PTY ?

I must connect to a server via putty using -t option ('enable PTY').
Connecting to this server does not work, I guess because I did not pass -t option.
How can I pass this option to WinSCP?