Post a reply

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)


Topic review


The other clients (OpenSSH sftp, pftp and FileZilla) do not use the lstat request.

Thank you! I thought everything logged to stdout when running as non daemon. I found the problem with SFTPLog setting.
LSTAT of '/test' blocked by <Limit> configuration

Removed all limits and now it works. Weird other clients doesn't use it that way. Not sure if that still is a problem with client or not, maybe they have some fallback method? But atleast now I can work around that.

I'm running debian buster in a container and the binary says ProFTPD Version 1.3.6. 1.3.6-4+deb10u5 should the version. I've run proftpd as
proftpd -n -d 10
so I'm not sure if I can get any more debug messages out.

It seems to work with sshd and cerberus, just not proftpd. But also only winscp that get this error message. Maybe the other clients uses some other method?

Re: Getting permission denied from server trying to browse subfolders

I do not know why the server fails the "lstat" request. What version on ProFTPD are you using? Can you get a more verbose server log file?

Getting permission denied from server trying to browse subfolders

Winscp 5.17.5. SFTP.
Running agaist proftpd that is running mod_sftp. If I connect to it with ftp it works.
I can connect and list files and folders but when I try to browse to a subfolder I get:
Permission denied.
Error code: 3
Error message from server (en-US): Permission denied

If I download the folder I get all the files and subfolders inside that folder and can browse them locally. I can also upload folders but not browse them.
On the server I have set permissions to 777 on all the files and folders.
Set SFTPClientMatch ".*WinSCP.*" sftpProtocolVersion 4 that a 2010 forum post suggested. Tried older versions within winscp.
Running without chroot.

Not sure if this is a problem with winscp or not, but I can't seem to replicate it on any other client (linux sftp, putty sftp, filezilla).