Post a reply

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)


Topic review


It's probably a firewall issue. Probably the firewall on your Windows Server 2012 machine does not allow outgoing connections to the FTP server data ports.

Hello !

I have found the solution.
The problem came from the firewall.
According to my research the range of ports needed to be widened.
It works now.
I hope this could help others.

Thanks for your support.

Hi !

Here are the files.

Thank you for trying to help me.

Re: Could not retrieve directory listing

Can you post log files from both machines?

Could not retrieve directory listing

Hello everybody !

I need some help to solve my problem.

I have set my WinSCP client on Windows 10 to connect to a remote server by using FTPS as protocol.

It works fine but if I try to configure my WinSCP client on Windows 2012 server R2 with the same settings, it does not work.

I got the following error message:

Timeout detected. (data connection)
Could not retrieve directory listing
Error listing directory '/'.

I have checked all my settings and I know it has nothing to do with the passive mode because I tried both of them ( Actif and passive).

I guess it is linked to Windows 2012 server R2.

I have already modified my windows Registry to allow TLS 1.1 ad TLS 1.2 but it has changed anything.

Does anyone know how to solve this ?

Thank you very much