Post a reply :: Support Forum

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Tip: Styles can be applied quickly to selected text.

Options
Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)

Options

Topic review

Guest

martin wrote:

Thanks for your info. What is your version of Windows? Please try to create the registry key as seen in my post. I believe it should help. Please, let me know.


I'm using win98 SE, and adding that key did help, thanks!
martin

Thanks for your info. What is your version of Windows? Please try to create the registry key as seen in my post. I believe it should help. Please, let me know.
carl

martin wrote:

carl wrote:

everything is in there, except "WinSCP Shell Extension" is in HKEY_CLASSES_ROOT\CLSID (in that main 'folder', not any of the sub ones)

I'm not sure what you mean, can you post a registry dump (similar to one I did)?


[HKEY_CLASSES_ROOT\CLSID]
@="WinSCP Shell Extension"

Enable is set to 1 (0x00000001) and I added LogFile to it, but no log file was created, even after I rebooted.
martin

carl wrote:

everything is in there, except "WinSCP Shell Extension" is in HKEY_CLASSES_ROOT\CLSID (in that main 'folder', not any of the sub ones)

I'm not sure what you mean, can you post a registry dump (similar to one I did)?

Also please check that the extension is enabled (in HKEY_CURRENT_USER and/or HKEY_LOCAL_MACHINE):

[HKEY_LOCAL_MACHINE\Software\Martin Prikryl\WinSCP 2\DragExt]
"Enable"=dword:00000001

Also you may turn on logging for the extension and post a log file:

[HKEY_LOCAL_MACHINE\Software\Martin Prikryl\WinSCP 2\DragExt]
"LogFile"="c:\\dragext.log"

Thanks for your patience. I'm really interested to solve this.
carl

martin wrote:

If you can work with Windows registry, please verify that following keys are present:

[HKEY_CLASSES_ROOT\CLSID\{E15E1D68-0D1C-49F7-BEB8-812B1E00FA60}]
@="WinSCP Shell Extension"

[HKEY_CLASSES_ROOT\CLSID\{E15E1D68-0D1C-49F7-BEB8-812B1E00FA60}\InProcServer32]
@="<path>\\DragExt.dll"
"ThreadingModel"="Apartment"

[HKEY_CLASSES_ROOT\directory\shellex\CopyHookHandlers\WinSCPCopyHook]
@="{E15E1D68-0D1C-49F7-BEB8-812B1E00FA60}"

And that path (<path>) in InProcServer32 is valid and the DLL is present there.


everything is in there, except "WinSCP Shell Extension" is in HKEY_CLASSES_ROOT\CLSID (in that main 'folder', not any of the sub ones)
martin

martin wrote:


You may need to restart your computer. Does it help?

nope

If you can work with Windows registry, please verify that following keys are present:

[HKEY_CLASSES_ROOT\CLSID\{E15E1D68-0D1C-49F7-BEB8-812B1E00FA60}]
@="WinSCP Shell Extension"

[HKEY_CLASSES_ROOT\CLSID\{E15E1D68-0D1C-49F7-BEB8-812B1E00FA60}\InProcServer32]
@="<path>\\DragExt.dll"
"ThreadingModel"="Apartment"

[HKEY_CLASSES_ROOT\directory\shellex\CopyHookHandlers\WinSCPCopyHook]
@="{E15E1D68-0D1C-49F7-BEB8-812B1E00FA60}"

And that path (<path>) in InProcServer32 is valid and the DLL is present there.
Guest

martin wrote:


You may need to restart your computer. Does it help?


nope
martin

carl wrote:

I installed the drag&drop shell extention, but in preferences the 'Use shell extention' option is grayed out.

You may need to restart your computer. Does it help?
carl

I installed the drag&drop shell extention, but in preferences the 'Use shell extention' option is grayed out.
martin

Re: How to switch "MOVE" mode and "COPY" mode?

Have you installed drag&drop shell extension? (note that you may have installed it, but it may be turned off in preferences)

1) If you did:
Copy should be a default operation.

2) If you did not:
Default operation is selected by target application. So if you drag to local panel of WinSCP, WinSCP should select copy. If you drag outside of WinSCP to Windows Explorer (desktop, folder, ...), Explorer selects default operation. It usually selects "move".
To force copy, hold down "Ctrl" key, just as with any other application. You should saw a hint in warning message on first move attempt, did you?

If anything above it not true for you, please let me know, it may be a bug.
hosakafrom JPN

How to switch "MOVE" mode and "COPY" mode?

Hi All!

I recently upgraded to WinSCP 3.5.6 from 3.5.0.
And I found all of my Drag'n'Drop actions from WinSCP are switched to "MOVE" mode.
Older version have "Allow move from remote directory" at "Preferences-Environment-Panels-Drag & Drop" but newest version have not.

Which configuration item would switch this back to normal "COPY" mode?

Thanks in advance.