Post a reply

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Options
Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)

Options

Topic review

Linda Kaioh

martin wrote:

Linda Kaioh wrote:

Just send it ^^

Thanks. Got it. I can reproduce the problem with the file. Working on a fix.


Thank you!
martin

Linda Kaioh wrote:

Just send it ^^

Thanks. Got it. I can reproduce the problem with the file. Working on a fix.
Linda Kaioh

martin wrote:

Linda Kaioh wrote:

Complete.

Can you email me a copy of the file from the local temporary folder? Any file that exhibits the problem would do.


Just send it ^^
martin

Re: Only small part of UTF-8 file is shown in internal editor

LALILU wrote:

i had the same problem with the internal editor at WinSCP version 5.0.7.2268 on Windows 7 Professional 64Bit.
Ive opened a file in the internal editor with windows-1251 encoding and switched with the "encoding"-Button on top to the utf-8 encoding.
The internal editor showed only 60 lines in utf-8 and 240 lines in windows-1251.

My solution was, go to the internal editor settings an choose utf-8 as default encoding.
Then ive closed the internal editor and opened the file again in die editor.
Now the editor shows all 240 lines in utf-8 AND all 240 lines when i switch to windows-1251 with the "encoding"-Button on top.

Are yyou aware that the "Encoding" button does not change file encoding? It only tell WinSCP in what encidong the file is. What encoding the file actually has?
martin

Linda Kaioh wrote:

Complete.

Can you email me a copy of the file from the local temporary folder? Any file that exhibits the problem would do.
LALILU

Re: Only small part of UTF-8 file is shown in internal editor

Linda Kaioh wrote:

LALILU wrote:

5.0.7.2268 on Windows 7 Professional 64Bit.
I?ve opened a file in the internal editor with windows-1251 encoding and switched with the "encoding"-Button on top to the utf-8 encoding.
The internal editor showed only 60 lines in utf-8 and 240 lines in windows-1251.

My solution was, go to the internal editor settings an choose utf-8 as default encoding.
Then i?ve closed the internal editor and opened the file again in die editor.
Now the editor shows all 240 lines in utf-8 AND all 240 lines when i switch to windows-1251 with the "encoding"-Button on top.

Maybe there is a first initial issue?

Greetz.


It doesn't help me. File I've tried to open is in UTF-8 with signature. It correctly detected as UTF-8 despite of default windows-1251 encoding.

I also set UTF-8 as default encoding and opened file still shown partially in UTF-8 mode.


I have another Problem.
Ive edited a utf-8 php-file with the interal editor.
After ive saved my changes by clicking the "save"-button my webserver doesnt run the script correctly.
Only a white site will be shown.
I must upload the original-file to run the script correctly.
I think there is an issue on file-saving in utf-8 editor.

Greetz.
Linda Kaioh

Re: Only small part of UTF-8 file is shown in internal editor

LALILU wrote:

5.0.7.2268 on Windows 7 Professional 64Bit.
I?ve opened a file in the internal editor with windows-1251 encoding and switched with the "encoding"-Button on top to the utf-8 encoding.
The internal editor showed only 60 lines in utf-8 and 240 lines in windows-1251.

My solution was, go to the internal editor settings an choose utf-8 as default encoding.
Then i?ve closed the internal editor and opened the file again in die editor.
Now the editor shows all 240 lines in utf-8 AND all 240 lines when i switch to windows-1251 with the "encoding"-Button on top.

Maybe there is a first initial issue?

Greetz.


It doesn't help me. File I've tried to open is in UTF-8 with signature. It correctly detected as UTF-8 despite of default windows-1251 encoding.

I also set UTF-8 as default encoding and opened file still shown partially in UTF-8 mode.
LALILU

Re: Only small part of UTF-8 file is shown in internal editor

Linda Kaioh wrote:

WinSCP version 5.0.7.2268 on Windows XP Prof SP3. Upgraded from 5.0.6.2074. Protocol is FTP. Using GUI in NC style.

I'm trying to edit text file from FTP server. Text file is in UTF-8 encoding with text in Russian. File name also contains cyrillic characters (server is FileZilla and it sends directory listing in UTF-8). I press F4 and wait for transfer to be completed. Then WinSCP shows internal editor. In this editor program shows only small part of file or in some cases niothing at all. In status bar it shows "UTF-8". When I switch to windows-1251 editor shows full text (not decoded).

So I think editor just incorectly decode UTF-8 text.


Hi,

i had the same problem with the internal editor at WinSCP version 5.0.7.2268 on Windows 7 Professional 64Bit.
Ive opened a file in the internal editor with windows-1251 encoding and switched with the "encoding"-Button on top to the utf-8 encoding.
The internal editor showed only 60 lines in utf-8 and 240 lines in windows-1251.

My solution was, go to the internal editor settings an choose utf-8 as default encoding.
Then ive closed the internal editor and opened the file again in die editor.
Now the editor shows all 240 lines in utf-8 AND all 240 lines when i switch to windows-1251 with the "encoding"-Button on top.

Maybe there is a first initial issue?

Greetz.
Linda Kaioh

Complete.
martin

Re: Only small part of UTF-8 file is shown in internal editor

Can you check the temporary file the edited files was downloaded to, if it is complete or not?
Linda Kaioh

Only small part of UTF-8 file is shown in internal editor

WinSCP version 5.0.7.2268 on Windows XP Prof SP3. Upgraded from 5.0.6.2074. Protocol is FTP. Using GUI in NC style.

I'm trying to edit text file from FTP server. Text file is in UTF-8 encoding with text in Russian. File name also contains cyrillic characters (server is FileZilla and it sends directory listing in UTF-8). I press F4 and wait for transfer to be completed. Then WinSCP shows internal editor. In this editor program shows only small part of file or in some cases niothing at all. In status bar it shows "UTF-8". When I switch to windows-1251 editor shows full text (not decoded).

So I think editor just incorectly decode UTF-8 text.