Post a reply

Tip: Styles can be applied quickly to selected text.

Options
Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)

Options

Topic review

martin

Re: Filemask not working on synchronize

Your mask is include mask, what basically means that it does not do anything, as the directories are included by default. To turn it to exclude mask, prepend it with pipe symbol:
synchronize local W:\directory1 "Text Files" -filemask="|*/"

See also https://winscp.net/eng/docs/file_mask
MisterDaniel

Filemask not working on synchronize

Hello,

I am trying to get synchronize to ignore files in the subdirectories (e.g.: "Text Files/Archive/file1.txt"), but it's not working so I'm guessing something is wrong with my code. Could you please advise me? Thanks!

open profile1

option transfer automatic
synchronize local W:\directory1 "Text Files" -filemask="*/"
close
open profile2
option transfer automatic
synchronize remote W:\directory1 "Files - Inbound" -filemask="*/"
close
exit